华为交换机vlan概念及创建

2018-12-03

  一、 vlan概念:

  vlan:将一个局域网在逻辑上划分多个广播域

  vlan标签4个字节:TPID,固定值,0x8100

  TCL:帧的控制信息

  1、 priority:帧的优先级(0-7)值越大优先级越高

  2、 CFI:MAC地址是否是经典格式,0表示经典,1表示非经典,以太网为0

  3、 Vlan ID

  以太网帧的格式:没有加上VLAN标记的标准以太网帧(untagged frame),有VLAN标记的以太网帧

  链路类型:

  1、access:接入链路

  PVID:代端口表缺省VLAN

  Access端口收到数据后会添加VLAN tag,VLAN ID和端口的PVID相同

  2、Trunk :当trunk端口收到帧,如果该帧不包含tag,将打上端口PVID,如果帧包含tag,则不变;当trunk端口发送帧时,该帧的VLAN ID 在trunk的允许发送列表中,若与端口的PVID相同,则剥离tag发送,若与端口的PVID不同,则直接发送

  3、hybrid:既可以连主机,又可以连交换机,可以以Taaged或Untagged方式加入vlan

  VLAN划分方法:端口,MAC地址,IP子网,协议,策略

  Voice VLAN应用:可以区分语音流量和业务流量,使语音流量优于业务流量,从而为语音流量提供保证

  二、 Vlan划分实例(拓扑图)

11111111111.png

  1、 s1创建vlan

  [S1]vlan batch 2 to 3 #创建一组连续的vlan

  [S1]vlan 2

  [S1-vlan2]description RED #对vlan2进行描述

  [S2]vlan 2 #创建单个vlan

  2、 配置access端口

  [S1-Ethernet0/0/1]port link-type access

  [S1-Ethernet0/0/1]port default vlan 1

  [S1-Ethernet0/0/2]port link-type access

  [S1-Ethernet0/0/2]port default vlan 2

  3、 配置trunk端口

  [S1-Ethernet0/0/1]port link-type trunk

  [S1-Ethernet0/0/1]port trunk allow-pass vlan all

  [S3]port-group group-number g0/0/1 to g0/0/2

  [S3-port-group]port link-type trunk

  [S2]port GigabitEthernet 0/0/1

  [S2-GigabitEthernet0/0/1]port link-type trunk

  [S2-GigabitEthernet0/0/1]port trunk allow-pass vlan all

  [S2]vlan 2

  [S1]interface g0/0/2

  [S1-GigabitEther0/0/2]port link-type trunk

  [S1-GigabitEther0/0/2]port turnk allow-pass vlan all

  [S4-GigabitEther0/0/1]port link-type trunk

  [S4-GigabitEther0/0/1]port trunk allow-pass vlan all

  本征vlan

  [S1-GigabitEthernet0/0/2]port trunk pvid vlan 2

  设置某个vlan不能通

  [S1-Gigabitether0/0/2]undo port trunk allow-pass vlan 2

  [S1-Gigabitether0/0/2]port trunk allow-pass vlan 2


分享到

CHINA'S LEADING IT SERVICE BRANDS

中国领先IT服务品牌企业

销售热线:400-017-5181
故障处理:400-617-5181
同创双子(北京)信息技术股份有限公司(英文简称“Gemini”)是一家IT服务公司。2016年新三板正式挂牌上市(股票代码:837868)。 联系我们 法律声明

微信客服

IT外包就扫我

Copyright© 同创双子(北京)信息技术股份有限公司 , 京ICP备16037308

网站地图

法律声明

未经本公司书面许可,任何单位及个人不得以任何方式或理由对上述产品、服务、信息、材料的任何部分进行使用、复制、修改、抄录、传播或与其它产品捆绑使用、销售。
凡侵犯本公司版权等知识产权的,本公司必依法追究其法律责任。
本公司法律事务部受本公司指示,特此郑重法律声明!